# CVE-2026-55437: Coder vulnerable to stored HTML injection via workspace agent logs in AgentLogLine component

> Attackers can inject malicious HTML into workspace agent logs, leading to stored XSS when victims view the dashboard, potentially compromising user accounts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-7qw2-f75v-62f7, GO-2026-5919

## What is CVE-2026-55437?

CVE-2026-55437 is a medium-severity cross-site scripting vulnerability in coder, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.17, 2.32.7, 2.33.8, and 2.34.2, the `AgentLogLine` dashboard component instantiated `ansi-to-html` without `escapeXML: true` and inserted the result via `dangerouslySetInnerHTML` so HTML embedded in workspace agent log lines was rendered as live markup. Server-side sanitization did not neutralize HTML metacharacters. Exploitation requires a victim to view attacker-controlled agent logs in the dashboard. The fix in versions 2.29.17, 2.32.7, 2.33.8, and 2.34.2 enables `escapeXML: true` so HTML metacharacters are escaped before DOM insertion. No known workarounds are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55437?

10 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17, 2.32.7, 2.33.8, 2.34.2 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | All versions | 2.29.17 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.30.0 | 2.32.7 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.33.0 | 2.33.8 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder/v2` | Go | From 2.34.0 | 2.34.2 |
| `github.com/coder/coder` | Go | All versions | None |

Products: Coder Coder.

## How do I fix CVE-2026-55437?

Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.17, 2.32.7, 2.33.8 or 2.34.2.

## Is CVE-2026-55437 being exploited?

There is no known exploitation of CVE-2026-55437 in the wild and no public exploit code.

## Other vulnerabilities in coder

- [CVE-2026-46354](https://insights.sbomify.com/CVE-2026-46354/): Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft (critical 9.1)
- [CVE-2026-55429](https://insights.sbomify.com/CVE-2026-55429/): Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID (high 8.7)
- [CVE-2026-55427](https://insights.sbomify.com/CVE-2026-55427/): Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh` (high 8.3)
- [CVE-2026-55428](https://insights.sbomify.com/CVE-2026-55428/): Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator (high 8.2)
- [CVE-2024-27918](https://insights.sbomify.com/CVE-2024-27918/): Coder's OIDC authentication allows email with partially matching domain to register (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55437 and fix it if it is affected.

What it is: CVE-2026-55437 is a medium-severity cross-site scripting vulnerability in coder, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55437 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17, 2.32.7, 2.33.8, 2.34.2
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected all versions; fixed in 2.29.17
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.30.0; fixed in 2.32.7
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.33.0; fixed in 2.33.8
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder/v2 (Go): affected from 2.34.0; fixed in 2.34.2
- github.com/coder/coder (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55437/ (Markdown: https://insights.sbomify.com/CVE-2026-55437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55437
- OSV: https://osv.dev/vulnerability/CVE-2026-55437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55437/
Summaries are generated and may contain mistakes; the official description above is the record.
