# CVE-2026-55442: Goobi viewer: cleanUpQuery double-brace bypass allows arbitrary Solr local-param injection


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2r24-qxpf-cj65

## What is CVE-2026-55442?

CVE-2026-55442 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 

### Official description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. From version 23.03 to before version 26.05, SolrTools.cleanUpQuery() strips Solr local-parameter syntax ({!...}) from user-supplied query strings before they reach Solr. Its regex can be bypassed by wrapping the local parameter in a second pair of curly braces ({{!...}}): the outer braces are stripped, the inner {!...} survives intact, and a valid Solr local parameter is forwarded. The flaw is in the shared sanitizer, so it affects any endpoint that routes user input through cleanUpQuery. The double-brace bypass applies from v23.10 (the greedy \{(.+)\} regex); a related bare-!join rewrap path is present. This issue has been patched in version 26.05.

Weakness: CWE-20 (Improper Input Validation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-55442?


## How do I fix CVE-2026-55442?

No fix has been published for CVE-2026-55442 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55442 being exploited?

There is no known exploitation of CVE-2026-55442 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55442 and fix it if it is affected.

What it is: CVE-2026-55442 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-55442 in the wild and no public exploit code.

Affected product: intranda goobi-viewer-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55442/ (Markdown: https://insights.sbomify.com/CVE-2026-55442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55442
- OSV: https://osv.dev/vulnerability/CVE-2026-55442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55442/
Summaries are generated and may contain mistakes; the official description above is the record.
