CVE-2026-55443 LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders
Attackers can read files outside the intended directory via path traversal in LangChain file-search middleware and loaders when processing untrusted input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55443?
CVE-2026-55443 is a medium-severity path traversal vulnerability in langchain-ai langchain, published on 22 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
LangChain is a framework for building agents and LLM-powered applications. Prior to 1.3.9, several LangChain components that resolve filesystem paths or expand search patterns do not consistently confine the resolved path to the intended root directory. Affected behaviors include: a file-search agent middleware that validates a starting directory but not the search pattern or the resolved target of matched files, so glob patterns and symlinks can reach files outside the configured root; prompt- and chain/agent-configuration loaders that accept path fields and resolve them without confining the result to a trusted base or rejecting symlink targets; and path-prefix authorization checks that compare by string prefix without a path-segment boundary, so a sibling path sharing the prefix is accepted. When these components receive path values, search patterns, or workspace contents influenced by an untrusted source — including an LLM acting on untrusted input — the result can be disclosure of files outside the intended boundary. This vulnerability is fixed in 1.3.9.
Which versions are affected by CVE-2026-55443?
6 open source packages ship an affected version, including langchain and langchain-anthropic. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
langchain PyPI | All versions | 1.3.9 |
langchain PyPI | All versions | 1.3.9 |
langchain PyPI | All versions | 1.3.9 |
langchain-anthropic PyPI | All versions | 1.4.6 |
langchain-anthropic PyPI | All versions | 1.4.6 |
langchain-anthropic PyPI | All versions | 1.4.6 |
Linux distribution packages (1)
python-langchain-anthropic openSUSE:Tumbleweed | All versions | 1.7.5-1.1 |
Products include Langchain Langchain.
How do I fix CVE-2026-55443?
Upgrade langchain to 1.3.9 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-55443 being exploited?
There is no known exploitation of CVE-2026-55443 in the wild and no public exploit code.
Other vulnerabilities in langchain-ai langchain
- CVE-2023-39631 Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
- CVE-2023-36281 langchain vulnerable to arbitrary code execution
- CVE-2023-38860 LangChain vulnerable to arbitrary code execution
- CVE-2023-38896 LangChain vulnerable to arbitrary code execution
- CVE-2023-39659 LangChain vulnerable to arbitrary code execution
Sources
Also known as CLEANSTART-2026-PK67408, ECHO-7afa-b4aa-5d4a, GHSA-gr75-jv2w-4656, PYSEC-2026-2192, PYSEC-2026-2556, ROOT-APP-PYPI-CVE-2026-55443 and 2 more.