# CVE-2026-55444: Goobi viewer: Solr query injection via the legacy RSS servlet q and filterQuery parameters


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-763m-wjm9-6873

## What is CVE-2026-55444?

CVE-2026-55444 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 

### Official description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. Prior to version 26.05, the legacy RSS servlet (RssResolver, GET /rss/) accepts the q and filterQuery parameters and concatenates them into Solr queries without validation. The servlet predates the REST API layer and lacks the input validation present in GET /api/v1/records/rss. q forms the main query body (wrapped only in literal parentheses); filterQuery is passed directly as a Solr fq. An unauthenticated attacker can inject Solr boolean operators to break out of the wrapping and render the trailing access-condition filter-query suffix optional, so that access-restricted records are included in the generated RSS feed. The q and filterQuery parameters are the same underlying vulnerability in the same servlet; q (the main query body) has the broader scope. This issue has been patched in version 26.05.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic), CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-55444?


## How do I fix CVE-2026-55444?

No fix has been published for CVE-2026-55444 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55444 being exploited?

There is no known exploitation of CVE-2026-55444 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55444 and fix it if it is affected.

What it is: CVE-2026-55444 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-55444 in the wild and no public exploit code.

Affected product: intranda goobi-viewer-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55444/ (Markdown: https://insights.sbomify.com/CVE-2026-55444/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55444
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55444
- OSV: https://osv.dev/vulnerability/CVE-2026-55444

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55444/
Summaries are generated and may contain mistakes; the official description above is the record.
