# CVE-2026-55445: Qinglong: Incomplete fix for CVE-2026-3965: Improper Authentication

> An unauthenticated attacker can reset administrator credentials by exploiting a path rewriting flaw in the authentication middleware.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-v667-gc2r-2xm7

## What is CVE-2026-55445?

CVE-2026-55445 is a critical authentication bypass vulnerability in whyour qinglong, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Qinglong is a timed task management platform supporting Python3, JavaScript, Shell, and Typescript. Prior to 2.20.1, the init guard middleware in back/loaders/express.ts checks /api/user/init but not /open/user/init, while rewrite('/open/*', '/api/$1') rewrites the whitelisted /open/* path after JWT authentication and the guard have passed; an unauthenticated attacker can send PUT /open/user/init to reset administrator credentials on an initialized instance. This issue is fixed in 2.20.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-55445?

2 open source packages ship an affected version, including @whyour/qinglong.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@whyour/qinglong` | npm | All versions | 2.20.1 |
| `@whyour/qinglong` | npm | All versions | 2.20.1 |

## How do I fix CVE-2026-55445?

Upgrade @whyour/qinglong to 2.20.1 or later.

## Is CVE-2026-55445 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55445 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55445 and fix it if it is affected.

What it is: CVE-2026-55445 is a critical authentication bypass vulnerability in whyour qinglong, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55445 exists.

Affected packages and fixed versions:
- @whyour/qinglong (npm): affected all versions; fixed in 2.20.1
- @whyour/qinglong (npm): affected all versions; fixed in 2.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55445/ (Markdown: https://insights.sbomify.com/CVE-2026-55445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55445
- OSV: https://osv.dev/vulnerability/CVE-2026-55445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55445/
Summaries are generated and may contain mistakes; the official description above is the record.
