# CVE-2026-55446: Langflow: Unauthenticated DoS through multipart form boundary file upload

> Unauthenticated attackers can cause indefinite denial of service in Langflow by sending requests with excessively long multipart form boundaries.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-qwqc-p3q8-wcg9, PYSEC-2026-223

## What is CVE-2026-55446?

CVE-2026-55446 is a high-severity denial of service vulnerability in Langflow Langflow, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.0.19, an attacker can send a /api/v1/files/upload/ request without any authentication token/cookies and abuse a very long multipart form boundary to make the langflow app unusable for all users for an indefinite amount of time. This vulnerability is fixed in 1.0.19.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55446?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.0.19 |
| `langflow` | PyPI | All versions | 1.0.19 |
| `langflow` | PyPI | All versions | 1.0.19 |

Products: Langflow Langflow.

## How do I fix CVE-2026-55446?

Upgrade langflow to 1.0.19 or later.

## Is CVE-2026-55446 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55446 exists.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55446 and fix it if it is affected.

What it is: CVE-2026-55446 is a high-severity denial of service vulnerability in Langflow Langflow, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55446 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.0.19
- langflow (PyPI): affected all versions; fixed in 1.0.19
- langflow (PyPI): affected all versions; fixed in 1.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55446/ (Markdown: https://insights.sbomify.com/CVE-2026-55446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55446
- OSV: https://osv.dev/vulnerability/CVE-2026-55446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55446/
Summaries are generated and may contain mistakes; the official description above is the record.
