# CVE-2026-55447: Langflow: BaseFileComponent-based nodes arbitrary file read with RCE exploit

> Attackers can read arbitrary files via path traversal in Langflow components, potentially leading to remote code execution.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-ccv6-r384-xp75, PYSEC-2026-378

## What is CVE-2026-55447?

CVE-2026-55447 is a critical path traversal vulnerability in Langflow Langflow, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.9.2, by controlling a files that are digested into the RAG, an attacker can direct the node to read any file on the file-system by absolute path. All components based on BaseFileComponent are vulnerable to the vulnerability. This includes Docling (DoclingInlineComponent), Docling Serve, DoclingRemoteComponent), Read File (FileComponent), NVIDIA Retriever Extraction (NvidiaIngestComponent), Video File (VideoFileComponent), and Unstructured API (UnstructuredComponent). This vulnerability is fixed in 1.9.2.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55447?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | All versions | 1.9.2 |
| `langflow` | PyPI | All versions | 1.9.2 |
| `langflow` | PyPI | All versions | 1.9.2 |

Products: Langflow Langflow.

## How do I fix CVE-2026-55447?

Upgrade langflow to 1.9.2 or later.

## Is CVE-2026-55447 being exploited?

There is no known exploitation of CVE-2026-55447 in the wild and no public exploit code.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55447 and fix it if it is affected.

What it is: CVE-2026-55447 is a critical path traversal vulnerability in Langflow Langflow, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55447 in the wild and no public exploit code.

Affected packages and fixed versions:
- langflow (PyPI): affected all versions; fixed in 1.9.2
- langflow (PyPI): affected all versions; fixed in 1.9.2
- langflow (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55447/ (Markdown: https://insights.sbomify.com/CVE-2026-55447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55447
- OSV: https://osv.dev/vulnerability/CVE-2026-55447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55447/
Summaries are generated and may contain mistakes; the official description above is the record.
