# CVE-2026-55448: mise: Local credential_command executes untrusted config

> Attackers can execute arbitrary shell commands via malicious local config files in mise when resolving GitHub tokens.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-29hf-rm4x-xxph

## What is CVE-2026-55448?

CVE-2026-55448 is a medium-severity command injection vulnerability in jdx mise, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

mise manages dev tools like node, python, cmake, and terraform. From 2026.3.15 until 2026.6.4, mise loads github.credential_command from local project config before any trust decision, then executes that value with sh -c when resolving a GitHub token. An attacker who can place a .mise.toml in a repository can execute arbitrary shell commands when the victim runs a GitHub-related mise command and no higher-priority GitHub token environment variable is set. This vulnerability is fixed in 2026.6.4.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55448?

2 open source packages ship an affected version, including mise.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mise` | crates.io | From 2026.3.15 | 2026.6.4 |
| `mise` | crates.io | From 2026.3.15 | 2026.6.4 |

## How do I fix CVE-2026-55448?

Upgrade mise to 2026.6.4 or later.

## Is CVE-2026-55448 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55448 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55448 and fix it if it is affected.

What it is: CVE-2026-55448 is a medium-severity command injection vulnerability in jdx mise, published on 26 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55448 exists.

Affected packages and fixed versions:
- mise (crates.io): affected from 2026.3.15; fixed in 2026.6.4
- mise (crates.io): affected from 2026.3.15; fixed in 2026.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55448/ (Markdown: https://insights.sbomify.com/CVE-2026-55448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55448
- OSV: https://osv.dev/vulnerability/CVE-2026-55448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55448/
Summaries are generated and may contain mistakes; the official description above is the record.
