# CVE-2026-55451: gettext-converter: Prototype pollution in js2i18next() via crafted translation keys

> Prototype pollution in gettext-converter allows attackers to modify Object.prototype via crafted translation keys, causing denial of service or application-specific issues.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-f4jp-rw7w-ccwg

## What is CVE-2026-55451?

CVE-2026-55451 is a high-severity vulnerability in locize gettext-converter, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

gettext-converter provides gettext resource conversion utilities for JavaScript. Prior to 1.3.3, js2i18next() in lib/js2i18next.js splits nested translation keys using options.keyseparator, whose default value consists of two number signs, and uses each segment as a dynamic object key without rejecting __proto__, constructor, or prototype. When an application converts untrusted PO or i18next translation data, a __proto__ segment resolves Object.prototype as the nested write target and Object.assign writes attacker-controlled translated properties onto the process-wide prototype. The resulting prototype pollution can cause denial of service and may enable application-dependent follow-on attacks. This issue is fixed in version 1.3.3.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-55451?

2 open source packages ship an affected version, including gettext-converter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gettext-converter` | npm | All versions | 1.3.3 |
| `gettext-converter` | npm | All versions | 1.3.3 |

## How do I fix CVE-2026-55451?

Upgrade gettext-converter to 1.3.3 or later.

## Is CVE-2026-55451 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55451 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55451 and fix it if it is affected.

What it is: CVE-2026-55451 is a high-severity vulnerability in locize gettext-converter, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55451 exists.

Affected packages and fixed versions:
- gettext-converter (npm): affected all versions; fixed in 1.3.3
- gettext-converter (npm): affected all versions; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55451/ (Markdown: https://insights.sbomify.com/CVE-2026-55451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55451
- OSV: https://osv.dev/vulnerability/CVE-2026-55451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55451/
Summaries are generated and may contain mistakes; the official description above is the record.
