# CVE-2026-55453: CUPS ipp backend status-line injection can update queue PPD and lead to conditional RCE as lp via foomatic-rip

> Remote attackers can inject newlines into IPP responses to modify PPD settings, leading to command execution as the lp user via Foomatic filters.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** AZL-108287, BELL-CVE-2026-55453, CLSA-2026-1792768682, CLSA-2026-1792768763, DEBIAN-CVE-2026-55453, ECHO-e4db-2416-74ec, GHSA-7hqf-mfhx-7r3v, UBUNTU-CVE-2026-55453

## What is CVE-2026-55453?

CVE-2026-55453 is a low-severity command injection vulnerability in OpenPrinting cups, published on 15 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.20, the backend/ipp.c quote_string() function preserves carriage-return and line-feed characters in a remote printer-controlled marker-message before report_attr() writes the value to the scheduler status stream. The scheduler can parse an injected newline as a separate PPD: control line and persist an attacker-selected PPD keyword. The reporter demonstrated that a later print job on a Foomatic-backed queue could consume an injected FoomaticRIPCommandLine value and execute in the filter context as lp. This issue is fixed in version 2.4.20.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-55453?

It affects 1 product.


Products: Openprinting Cups.

## How do I fix CVE-2026-55453?

Upgrade to a fixed version.

## Is CVE-2026-55453 being exploited?

There is no known exploitation of CVE-2026-55453 in the wild and no public exploit code.

## Other vulnerabilities in OpenPrinting cups

- [CVE-2025-58060](https://insights.sbomify.com/CVE-2025-58060/): cups has Authentication bypass with AuthType Negotiate (high 8.0)
- [CVE-2026-34978](https://insights.sbomify.com/CVE-2026-34978/): Path traversal in cups (medium 6.5)
- [CVE-2025-58364](https://insights.sbomify.com/CVE-2025-58364/): cups: Remote DoS via null dereference (medium 6.5)
- [CVE-2026-34980](https://insights.sbomify.com/CVE-2026-34980/): OpenPrinting CUPS: Shared PostScript queue lets anonymous Print-Job requests reach `lp` code execution over the network (medium 6.1)
- [CVE-2025-61915](https://insights.sbomify.com/CVE-2025-61915/): OpenPrinting CUPS vulnerable to stack based out-of-bound write (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55453 and fix it if it is affected.

What it is: CVE-2026-55453 is a low-severity command injection vulnerability in OpenPrinting cups, published on 15 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55453 in the wild and no public exploit code.

Affected product: OpenPrinting cups. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55453/ (Markdown: https://insights.sbomify.com/CVE-2026-55453/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55453
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55453
- OSV: https://osv.dev/vulnerability/CVE-2026-55453

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55453/
Summaries are generated and may contain mistakes; the official description above is the record.
