# CVE-2026-55463: Goobi viewer: WebSocket endpoints lack server-side authentication and origin validation


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-h5m9-fpvw-qr36

## What is CVE-2026-55463?

CVE-2026-55463 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 

### Official description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. From version 4.11.0 to before version 26.05, several Jakarta WebSocket endpoints in goobi-viewer-core (DownloadTaskEndpoint, CampaignEndpoint, AutocompleteEndpoint, UserEndpoint) accept connections without verifying that the associated HttpSession belongs to a logged-in user, and none validate the Origin header against an allowlist. An unauthenticated attacker can therefore connect to these endpoints; through CampaignEndpoint this allows polluting the in-process crowdsourcing page-lock map and broadcasting forged lock messages, disrupting reviewers' work. This issue has been patched in version 26.05.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality), CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-55463?


## How do I fix CVE-2026-55463?

No fix has been published for CVE-2026-55463 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55463 being exploited?

There is no known exploitation of CVE-2026-55463 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55463 and fix it if it is affected.

What it is: CVE-2026-55463 is a medium-severity vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-55463 in the wild and no public exploit code.

Affected product: intranda goobi-viewer-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55463/ (Markdown: https://insights.sbomify.com/CVE-2026-55463/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55463
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55463
- OSV: https://osv.dev/vulnerability/CVE-2026-55463

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55463/
Summaries are generated and may contain mistakes; the official description above is the record.
