CVE-2026-55468 Wagtail: Improper restriction handling on Pages admin API
An attacker with admin access can retrieve restricted draft and live page content via the Pages admin API due to insufficient access control.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55468?
CVE-2026-55468 is a medium-severity missing authorization vulnerability in wagtail, published on 24 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Wagtail is an open source content management system built on Django. Prior to versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2 on their respective release lines, the internal Pages admin API returns page fields declared in api_fields without sufficient access control, allowing a user with Wagtail admin access to retrieve restricted draft and live page content. This issue is fixed in versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2.
Weakness: CWE-280
Which versions are affected by CVE-2026-55468?
9 open source packages ship an affected version, including wagtail.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | All versions | 7.0.9, 7.3.4, 7.4.3, 8.0rc2 |
wagtail PyPI | All versions | 7.0.9 |
wagtail PyPI | All versions | 7.0.9 |
wagtail PyPI | From 7.1 | 7.3.4 |
wagtail PyPI | From 7.1 | 7.3.4 |
wagtail PyPI | From 7.4 | 7.4.3 |
3 more packages
wagtail PyPI | From 7.4 | 7.4.3 |
wagtail PyPI | From 8.0rc1 | 8.0rc2 |
wagtail PyPI | From 8.0rc1 | 8.0rc2 |
How do I fix CVE-2026-55468?
Upgrade wagtail to a fixed version for your release line: 7.0.9, 7.3.4, 7.4.3 or 8.0rc2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55468 being exploited?
There is no known exploitation of CVE-2026-55468 in the wild and no public exploit code.
Sources
Also known as GHSA-3vrh-m9w7-v94f, PYSEC-2026-3939.