# CVE-2026-55468: Wagtail: Improper restriction handling on Pages admin API

> An attacker with admin access can retrieve restricted draft and live page content via the Pages admin API due to insufficient access control.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-3vrh-m9w7-v94f, PYSEC-2026-3939

## What is CVE-2026-55468?

CVE-2026-55468 is a medium-severity missing authorization vulnerability in wagtail, published on 24 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Wagtail is an open source content management system built on Django. Prior to versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2 on their respective release lines, the internal Pages admin API returns page fields declared in api_fields without sufficient access control, allowing a user with Wagtail admin access to retrieve restricted draft and live page content. This issue is fixed in versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2.

Weakness: CWE-280 (Improper Handling of Insufficient Permissions or Privileges)

## Which versions are affected by CVE-2026-55468?

9 open source packages ship an affected version, including wagtail.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 7.0.9, 7.3.4, 7.4.3, 8.0rc2 |
| `wagtail` | PyPI | All versions | 7.0.9 |
| `wagtail` | PyPI | All versions | 7.0.9 |
| `wagtail` | PyPI | From 7.1 | 7.3.4 |
| `wagtail` | PyPI | From 7.1 | 7.3.4 |
| `wagtail` | PyPI | From 7.4 | 7.4.3 |
| `wagtail` | PyPI | From 7.4 | 7.4.3 |
| `wagtail` | PyPI | From 8.0rc1 | 8.0rc2 |
| `wagtail` | PyPI | From 8.0rc1 | 8.0rc2 |

## How do I fix CVE-2026-55468?

Upgrade wagtail to a fixed version for your release line: 7.0.9, 7.3.4, 7.4.3 or 8.0rc2.

## Is CVE-2026-55468 being exploited?

There is no known exploitation of CVE-2026-55468 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55468 and fix it if it is affected.

What it is: CVE-2026-55468 is a medium-severity missing authorization vulnerability in wagtail, published on 24 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55468 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 7.0.9, 7.3.4, 7.4.3, 8.0rc2
- wagtail (PyPI): affected all versions; fixed in 7.0.9
- wagtail (PyPI): affected all versions; fixed in 7.0.9
- wagtail (PyPI): affected from 7.1; fixed in 7.3.4
- wagtail (PyPI): affected from 7.1; fixed in 7.3.4
- wagtail (PyPI): affected from 7.4; fixed in 7.4.3
- wagtail (PyPI): affected from 7.4; fixed in 7.4.3
- wagtail (PyPI): affected from 8.0rc1; fixed in 8.0rc2
- wagtail (PyPI): affected from 8.0rc1; fixed in 8.0rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55468/ (Markdown: https://insights.sbomify.com/CVE-2026-55468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55468
- OSV: https://osv.dev/vulnerability/CVE-2026-55468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55468/
Summaries are generated and may contain mistakes; the official description above is the record.
