# CVE-2026-55469: Snipe-IT: Path traversal vulnerability via CSV import `image` field


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-xr9m-gphc-9p63

## What is CVE-2026-55469?

CVE-2026-55469 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 10 Jul 2026. 

### Official description

Snipe-IT is an IT asset/license management system. Prior to 8.6.2, an authenticated user with import and assets.update permissions can place a path traversal string in an asset image field through CSV import and then trigger image deletion, allowing deletion of arbitrary files accessible to the server process. This issue is fixed in version 8.6.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55469?

2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snipe/snipe-it` | Packagist | All versions | 8.6.2 |
| `snipe/snipe-it` | Packagist | All versions | 8.6.2 |

Products: Snipeitapp Snipe-It.

## How do I fix CVE-2026-55469?

Upgrade snipe/snipe-it to 8.6.2 or later.

## Is CVE-2026-55469 being exploited?

There is no known exploitation of CVE-2026-55469 in the wild and no public exploit code.

## Other vulnerabilities in Snipeitapp Snipe-It

- [CVE-2025-63601](https://insights.sbomify.com/CVE-2025-63601/): File upload in n/a (critical 9.9)
- [CVE-2026-37709](https://insights.sbomify.com/CVE-2026-37709/): Snipe-IT has insecure permissions in file uploads (critical 9.8)
- [CVE-2026-86738](https://insights.sbomify.com/CVE-2026-86738/): Snipe-IT before 8.7.0 CSS Injection via Custom CSS (critical 9.3)
- [CVE-2026-116199](https://insights.sbomify.com/CVE-2026-116199/): Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback (critical 9.2)
- [CVE-2022-1380](https://insights.sbomify.com/CVE-2022-1380/): Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55469 and fix it if it is affected.

What it is: CVE-2026-55469 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 10 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-55469 in the wild and no public exploit code.

Affected packages and fixed versions:
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.6.2
- snipe/snipe-it (Packagist): affected all versions; fixed in 8.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55469/ (Markdown: https://insights.sbomify.com/CVE-2026-55469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55469
- OSV: https://osv.dev/vulnerability/CVE-2026-55469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55469/
Summaries are generated and may contain mistakes; the official description above is the record.
