# CVE-2026-55470: HAPI FHIR: DSTU2 FHIRPathEngine.matches() missing RegexTimeout protection allows ReDoS

> An unauthenticated attacker can cause server CPU exhaustion via catastrophic regex backtracking in the HAPI FHIR DSTU2 module.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-fxj4-p9xp-37v5, ROOT-APP-MAVEN-CVE-2026-55470

## What is CVE-2026-55470?

CVE-2026-55470 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.10, the fix for CVE-2026-45367 incompletely patched the DSTU2 module, leaving FHIRPathEngine.matches() in org.hl7.fhir.dstu2/utils/FHIRPathEngine.java to call raw String.matches(sw) without RegexTimeout protection while replaceMatches() was updated, allowing an unauthenticated attacker to trigger catastrophic regex backtracking and exhaust server CPU. This issue is fixed in version 6.9.10.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-55470?

8 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.convertors, ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 and ca.uhn.hapi.fhir:org.hl7.fhir.validation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.convertors` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.convertors` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.10 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli` | Maven | All versions | 6.9.10 |

Products: Hapifhir Hl7 Fhir Core.

## How do I fix CVE-2026-55470?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.convertors to 6.9.10 or later.

## Is CVE-2026-55470 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55470 exists.

## Other vulnerabilities in hapifhir org.hl7.fhir.core

- [CVE-2026-34361](https://insights.sbomify.com/CVE-2026-34361/): HAPI FHIR: Unauthenticated SSRF via /loadIG Chains with startsWith() Credential Leak for Authentication Token Theft (critical 9.3)
- [CVE-2026-55471](https://insights.sbomify.com/CVE-2026-55471/): HAPI FHIR: XXE in XsltUtilities.saxonTransform via unhardened Saxon TransformerFactory (high 8.7)
- [CVE-2023-24057](https://insights.sbomify.com/CVE-2023-24057/): MITM based Zip Slip in `ca.uhn.hapi.fhir:org.hl7.fhir.core` (high 8.1)
- [CVE-2023-28465](https://insights.sbomify.com/CVE-2023-28465/): HL7 FHIR Partial Path Zip Slip due to bypass of CVE-2023-24057 (high 7.5)
- [CVE-2026-34359](https://insights.sbomify.com/CVE-2026-34359/): HAPI FHIR: Authentication Credential Leakage via Improper URL Prefix Matching on HTTP Redirect in HAPI FHIR Core (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55470 and fix it if it is affected.

What it is: CVE-2026-55470 is a high-severity denial of service vulnerability in hapifhir org.hl7.fhir.core, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55470 exists.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.convertors (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.convertors (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2 (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.validation (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.validation (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli (Maven): affected all versions; fixed in 6.9.10
- ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli (Maven): affected all versions; fixed in 6.9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55470/ (Markdown: https://insights.sbomify.com/CVE-2026-55470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55470
- OSV: https://osv.dev/vulnerability/CVE-2026-55470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55470/
Summaries are generated and may contain mistakes; the official description above is the record.
