{"answers":{"affected":"3 open source packages ship an affected version, including piccolo-admin.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55485 exists.","fix":"Upgrade piccolo-admin to 1.14.0 or later.","what":"CVE-2026-55485 is a high-severity vulnerability in piccolo-orm piccolo_admin, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55485 and fix it if it is affected.\n\nWhat it is: CVE-2026-55485 is a high-severity vulnerability in piccolo-orm piccolo_admin, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55485 exists.\n\nAffected packages and fixed versions:\n- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0\n- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0\n- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55485/ (Markdown: https://insights.sbomify.com/CVE-2026-55485/index.md)","id":"CVE-2026-55485","markdown":"https://insights.sbomify.com/CVE-2026-55485/index.md","name":"CVE-2026-55485","record":{"aliases":["GHSA-2gh4-jmwq-rr8w","PYSEC-2026-3882"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Piccolo Admin","requires_auth":"low_privilege","summary":"Non-superuser admins can escalate privileges to superuser by stealing session tokens via an exposed API endpoint in Piccolo Admin.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Piccolo Admin is an admin interface and content management system for Python, built on top of Piccolo. Prior to 1.14.0, piccolo_admin/endpoints.py uses superuser_validators to block PUT, PATCH, DELETE, and POST requests by non-superusers but permits GET requests to configured user and session tables, while piccolo_api/session_auth/tables.py exposes SessionsBase.token because the token column is not secret. In deployments that add the Sessions and User tables to create_admin, a non-superuser administrator can call GET /api/tables/sessions/, obtain another user's live session token, replay it as the Cookie id value to impersonate a superuser, and permanently set superuser to true on the attacker's own row. This issue is fixed in version 1.14.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Piccolo Admin: Privilege escalation - admin to superuser via session-token disclosure in GET /api/tables/sessions/.","id":"CVE-2026-55485","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":3,"n_references":6,"next":{"headline":"Goobi viewer: IIIF Auth 2.0 origin parameter unsanitized — CSP malformation and reflected XSS","id":"CVE-2026-55486"},"packages":[{"ecosystem":"PyPI","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"piccolo-admin","purl":null,"source":"GHSA-2gh4-jmwq-rr8w"},{"ecosystem":"PyPI","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"piccolo-admin","purl":"pkg:pypi/piccolo-admin","source":"GHSA-2gh4-jmwq-rr8w"},{"ecosystem":"PyPI","fixed":["1.14.0"],"introduced":["0"],"last_affected":[],"package":"piccolo-admin","purl":"pkg:pypi/piccolo-admin","source":"PYSEC-2026-3882"}],"prev":{"headline":"alos-http has unauthenticated remote DoS: malformed path starting with \"?\" triggers out-of-bounds panic in sanitizeRequestPath, crashing entire server","id":"CVE-2026-55484"},"products":["piccolo_admin"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-31","vendors":["piccolo-orm"]},"summary":"Non-superuser admins can escalate privileges to superuser by stealing session tokens via an exposed API endpoint in Piccolo Admin.","url":"https://insights.sbomify.com/CVE-2026-55485/"}