# CVE-2026-55485: Piccolo Admin: Privilege escalation - admin to superuser via session-token disclosure in GET /api/tables/sessions/.

> Non-superuser admins can escalate privileges to superuser by stealing session tokens via an exposed API endpoint in Piccolo Admin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-2gh4-jmwq-rr8w, PYSEC-2026-3882

## What is CVE-2026-55485?

CVE-2026-55485 is a high-severity vulnerability in piccolo-orm piccolo_admin, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Piccolo Admin is an admin interface and content management system for Python, built on top of Piccolo. Prior to 1.14.0, piccolo_admin/endpoints.py uses superuser_validators to block PUT, PATCH, DELETE, and POST requests by non-superusers but permits GET requests to configured user and session tables, while piccolo_api/session_auth/tables.py exposes SessionsBase.token because the token column is not secret. In deployments that add the Sessions and User tables to create_admin, a non-superuser administrator can call GET /api/tables/sessions/, obtain another user's live session token, replay it as the Cookie id value to impersonate a superuser, and permanently set superuser to true on the attacker's own row. This issue is fixed in version 1.14.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55485?

3 open source packages ship an affected version, including piccolo-admin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `piccolo-admin` | PyPI | All versions | 1.14.0 |
| `piccolo-admin` | PyPI | All versions | 1.14.0 |
| `piccolo-admin` | PyPI | All versions | 1.14.0 |

## How do I fix CVE-2026-55485?

Upgrade piccolo-admin to 1.14.0 or later.

## Is CVE-2026-55485 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55485 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55485 and fix it if it is affected.

What it is: CVE-2026-55485 is a high-severity vulnerability in piccolo-orm piccolo_admin, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55485 exists.

Affected packages and fixed versions:
- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0
- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0
- piccolo-admin (PyPI): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55485/ (Markdown: https://insights.sbomify.com/CVE-2026-55485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55485
- OSV: https://osv.dev/vulnerability/CVE-2026-55485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55485/
Summaries are generated and may contain mistakes; the official description above is the record.
