# CVE-2026-55486: Goobi viewer: IIIF Auth 2.0 origin parameter unsanitized — CSP malformation and reflected XSS


- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-975w-g9gj-xq48

## What is CVE-2026-55486?

CVE-2026-55486 is a critical vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 

### Official description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. From version 25.08 to before version 26.05, the IIIF Auth 2.0 endpoints auth/login and auth/token in AuthorizationFlowResource accept an origin query parameter without validation and then (1) embed it into the Content-Security-Policy: frame-ancestors response header and (2) embed it into an HTML response body as a JavaScript single-quoted postMessage argument. Because the attacker controls both the login and token calls that initiate the flow, the unescaped value yields reflected XSS. This issue has been patched in version 26.05.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-55486?


## How do I fix CVE-2026-55486?

No fix has been published for CVE-2026-55486 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55486 being exploited?

There is no known exploitation of CVE-2026-55486 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55486 and fix it if it is affected.

What it is: CVE-2026-55486 is a critical vulnerability in intranda goobi-viewer-core, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-55486 in the wild and no public exploit code.

Affected product: intranda goobi-viewer-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55486/ (Markdown: https://insights.sbomify.com/CVE-2026-55486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55486
- OSV: https://osv.dev/vulnerability/CVE-2026-55486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55486/
Summaries are generated and may contain mistakes; the official description above is the record.
