# CVE-2026-55487: pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle

> Attackers can spoof package identities to bypass build approval checks, executing arbitrary code during installation in pnpm.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-5wx6-mg75-v57r, MINI-x9m6-fwrh-r6p5, ROOT-APP-NPM-CVE-2026-55487

## What is CVE-2026-55487?

CVE-2026-55487 is a high-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.2 and 11.5.3, the generic peer-suffix normalizer also stripped parenthesized text from git, URL, tarball, file, and other opaque locators. Approval for one source string could therefore authorize a different attacker-controlled source whose locator normalized to the same value. This vulnerability is fixed in 10.34.2 and 11.5.3.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-693 (Protection Mechanism Failure), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-55487?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | All versions | 10.34.2 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |
| `pnpm` | npm | From 11.0.0 | 11.5.3 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-55487?

Upgrade pnpm to a fixed version for your release line: 10.34.2 or 11.5.3.

## Is CVE-2026-55487 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55487 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55487 and fix it if it is affected.

What it is: CVE-2026-55487 is a high-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55487 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected all versions; fixed in 10.34.2
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3
- pnpm (npm): affected from 11.0.0; fixed in 11.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55487/ (Markdown: https://insights.sbomify.com/CVE-2026-55487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55487
- OSV: https://osv.dev/vulnerability/CVE-2026-55487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55487/
Summaries are generated and may contain mistakes; the official description above is the record.
