# CVE-2026-55496: Cloudreve: Information Exposure in `GET /api/v4/user/search`: `SearchActive` omits the active-status predicate, leaking inactive/banned account emails

> Logged-in users can enumerate email addresses and profile metadata of inactive or banned accounts due to a missing status filter in the user search API.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-8r7f-r8hj-r3rv, GO-2026-6098

## What is CVE-2026-55496?

CVE-2026-55496 is a medium-severity vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.17.0, GET /api/v4/user/search calls SearchActive without adding a StatusActive predicate and serializes matches at RedactLevelUser, allowing any logged-in user to enumerate email addresses and profile metadata for inactive or banned accounts. The service calls userClient.SearchActive, but despite its name that method filters only by email/nickname keyword and never adds a StatusActive predicate — while the sibling lookups GetActiveByID and GetActiveByDavAccount, defined a few lines above it, do. Search hits are serialized at RedactLevelUser, which includes the email address. This issue is fixed in version 4.17.0.

Weakness: CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55496?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260613023921-7e1289d55279 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260613023921-7e1289d55279 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260613023921-7e1289d55279 |

## How do I fix CVE-2026-55496?

Upgrade to a fixed version.

## Is CVE-2026-55496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55496 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55496 and fix it if it is affected.

What it is: CVE-2026-55496 is a medium-severity vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55496 exists.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260613023921-7e1289d55279
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260613023921-7e1289d55279
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260613023921-7e1289d55279

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55496/ (Markdown: https://insights.sbomify.com/CVE-2026-55496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55496
- OSV: https://osv.dev/vulnerability/CVE-2026-55496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55496/
Summaries are generated and may contain mistakes; the official description above is the record.
