CVE-2026-55500 9routers has Exposure of Sensitive Information and Unprotected Database Import/Export, Allowing Complete Credential Theft and Database Takeover

Critical 9.9 Published Updated

Unauthenticated access to database import/export endpoints allows attackers to steal credentials and overwrite the database in 9Router.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-55500?

CVE-2026-55500 is a critical missing authorization vulnerability in decolua 9router, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

9Router is an AI router & token saver. Prior to 0.4.80, the /api/settings/database endpoint allows full database export (containing all credentials, API keys, OAuth tokens, and settings) and full database import (complete overwrite) without any authentication requirement beyond the ALWAYS_PROTECTED middleware check, which only validates JWT or CLI token. This issue is fixed in version 0.4.80.

Weakness: CWE-200

Which versions are affected by CVE-2026-55500?

2 open source packages ship an affected version, including 9router.

PackageAffectedFixed in
9router npmAll versions to 0.4.71None
9router npmAll versions to 0.4.71None

How do I fix CVE-2026-55500?

No fix has been published for CVE-2026-55500 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-55500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55500 exists.

Sources

Also known as GHSA-qvfm-67h2-2qfx.

Is CVE-2026-55500 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free