# CVE-2026-55500: 9routers has Exposure of Sensitive Information and Unprotected Database Import/Export, Allowing Complete Credential Theft and Database Takeover

> Unauthenticated access to database import/export endpoints allows attackers to steal credentials and overwrite the database in 9Router.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-qvfm-67h2-2qfx

## What is CVE-2026-55500?

CVE-2026-55500 is a critical missing authorization vulnerability in decolua 9router, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.4.80, the /api/settings/database endpoint allows full database export (containing all credentials, API keys, OAuth tokens, and settings) and full database import (complete overwrite) without any authentication requirement beyond the ALWAYS_PROTECTED middleware check, which only validates JWT or CLI token. This issue is fixed in version 0.4.80.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55500?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions to 0.4.71 | None |
| `9router` | npm | All versions to 0.4.71 | None |

## How do I fix CVE-2026-55500?

No fix has been published for CVE-2026-55500 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55500 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55500 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55500 and fix it if it is affected.

What it is: CVE-2026-55500 is a critical missing authorization vulnerability in decolua 9router, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55500 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions up to 0.4.71; no fix listed
- 9router (npm): affected all versions up to 0.4.71; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55500/ (Markdown: https://insights.sbomify.com/CVE-2026-55500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55500
- OSV: https://osv.dev/vulnerability/CVE-2026-55500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55500/
Summaries are generated and may contain mistakes; the official description above is the record.
