# CVE-2026-55501: 9router: Login brute-force protection bypass via spoofed X-Forwarded-For header

> Attackers can bypass login rate limits by spoofing the X-Forwarded-For header, enabling unlimited brute-force attacks against dashboard credentials.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-7cfm-pqrj-xgq7

## What is CVE-2026-55501?

CVE-2026-55501 is a high-severity vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.4.80, the dashboard login rate limiter in src/lib/auth/loginLimiter.js derives the client identity from the attacker-controlled X-Forwarded-For HTTP header, and src/app/api/auth/login/route.js uses that spoofable value for checkLock and recordFail. A remote attacker can rotate the X-Forwarded-For value on each login attempt to receive a fresh rate-limit bucket, bypass the 5-attempt threshold and progressive lockout durations, and perform unlimited brute-force attempts against the dashboard password. This issue is fixed in version 0.4.80.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-55501?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.4.77 |
| `9router` | npm | All versions | 0.4.77 |

## How do I fix CVE-2026-55501?

Upgrade 9router to 0.4.77 or later.

## Is CVE-2026-55501 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55501 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55501 and fix it if it is affected.

What it is: CVE-2026-55501 is a high-severity vulnerability in decolua 9router, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55501 exists.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.4.77
- 9router (npm): affected all versions; fixed in 0.4.77

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55501/ (Markdown: https://insights.sbomify.com/CVE-2026-55501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55501
- OSV: https://osv.dev/vulnerability/CVE-2026-55501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55501/
Summaries are generated and may contain mistakes; the official description above is the record.
