CVE-2026-55502 Cloudreve: OAuth Admin.Read scope can update OneDrive storage policy credentials

High 7.1 Published Updated

An attacker with Admin.Read scope can modify OneDrive storage policy credentials due to missing Admin.Write authorization checks on a specific API route.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55502?

CVE-2026-55502 is a high-severity missing authorization vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.17.0, POST /api/v4/admin/policy/oauth/signin requires only Admin.Read even though GetOauthRedirectService persists caller-supplied OneDrive secret and app_id values, allowing an OAuth token without Admin.Write to modify storage policy credentials. The route is inside the admin group that requires Admin.Read, but it does not add the local Admin.Write guard used by sibling policy mutation routes. Its handler persists attacker-supplied secret and app_id values into the selected OneDrive storage policy before returning an OAuth URL. This issue is fixed in version 4.17.0.

Weakness: CWE-863

Which versions are affected by CVE-2026-55502?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.

PackageAffectedFixed in
github.com/cloudreve/Cloudreve/v3 GoAll versionsNone
github.com/cloudreve/Cloudreve/v3 GoAll versions to 3.0.0-20250225100611-da4e44b77af4None
github.com/cloudreve/Cloudreve/v3 GoAll versions to 3.0.0-20250225100611-da4e44b77af4None
github.com/cloudreve/Cloudreve GoAll versionsNone
github.com/cloudreve/Cloudreve/v4 GoAll versionsNone
github.com/cloudreve/Cloudreve/v4 GoAll versions4.17.0
1 more packages
github.com/cloudreve/Cloudreve/v4 GoAll versions4.17.0

How do I fix CVE-2026-55502?

Upgrade to a fixed version.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-55502 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55502 exists.

Sources

Also known as GHSA-hq88-5x99-x3gf, GO-2026-6101.

Is CVE-2026-55502 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free