# CVE-2026-55502: Cloudreve: OAuth Admin.Read scope can update OneDrive storage policy credentials

> An attacker with Admin.Read scope can modify OneDrive storage policy credentials due to missing Admin.Write authorization checks on a specific API route.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-hq88-5x99-x3gf, GO-2026-6101

## What is CVE-2026-55502?

CVE-2026-55502 is a high-severity missing authorization vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.17.0, POST /api/v4/admin/policy/oauth/signin requires only Admin.Read even though GetOauthRedirectService persists caller-supplied OneDrive secret and app_id values, allowing an OAuth token without Admin.Write to modify storage policy credentials. The route is inside the admin group that requires Admin.Read, but it does not add the local Admin.Write guard used by sibling policy mutation routes. Its handler persists attacker-supplied secret and app_id values into the selected OneDrive storage policy before returning an OAuth URL. This issue is fixed in version 4.17.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-55502?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.17.0 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.17.0 |

## How do I fix CVE-2026-55502?

Upgrade to a fixed version.

## Is CVE-2026-55502 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55502 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55502 and fix it if it is affected.

What it is: CVE-2026-55502 is a high-severity missing authorization vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55502 exists.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.17.0
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55502/ (Markdown: https://insights.sbomify.com/CVE-2026-55502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55502
- OSV: https://osv.dev/vulnerability/CVE-2026-55502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55502/
Summaries are generated and may contain mistakes; the official description above is the record.
