# CVE-2026-55509: WsgiDAV: Blind SQL injection in the MySQL provider

> An attacker can inject SQL via URL to extract arbitrary data from the database when using the non-default MySQL provider in WsgiDAV.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-p6gw-4frg-j7jw, PYSEC-2026-3945

## What is CVE-2026-55509?

CVE-2026-55509 is a high-severity SQL injection vulnerability in mar10 wsgidav, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WsgiDAV is a generic and extendable WebDAV server based on WSGI. Prior to 4.3.5, the sample MySQLBrowserProvider in wsgidav/samples/mysql_dav_provider.py concatenates the record key parsed from a request URL directly into SQL WHERE clauses. The affected _exists_record_by_primary_key, _get_field_by_primary_key, and _get_record_by_primary_key methods are part of a shipped example provider that is not enabled by default. An attacker who can access a share explicitly configured with this non-default provider can inject SQL through a normal GET request; anonymously exposed read shares permit a status-code oracle and extraction of arbitrary data reachable by the configured MySQL account. This issue is fixed in version 4.3.5.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-55509?

3 open source packages ship an affected version, including wsgidav and WsgiDAV.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wsgidav` | PyPI | All versions | 4.3.5 |
| `wsgidav` | PyPI | All versions | 4.3.5 |
| `WsgiDAV` | PyPI | All versions | 4.3.5 |

## How do I fix CVE-2026-55509?

Upgrade wsgidav to 4.3.5 or later.

## Is CVE-2026-55509 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55509 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55509 and fix it if it is affected.

What it is: CVE-2026-55509 is a high-severity SQL injection vulnerability in mar10 wsgidav, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55509 exists.

Affected packages and fixed versions:
- wsgidav (PyPI): affected all versions; fixed in 4.3.5
- wsgidav (PyPI): affected all versions; fixed in 4.3.5
- WsgiDAV (PyPI): affected all versions; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55509/ (Markdown: https://insights.sbomify.com/CVE-2026-55509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55509
- OSV: https://osv.dev/vulnerability/CVE-2026-55509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55509/
Summaries are generated and may contain mistakes; the official description above is the record.
