CVE-2026-55514 vLLM denial of service via prompt embeds on M-RoPE models

High 7.1 Published Updated

Remote attackers can crash the vLLM server by sending specific prompt embeds to M-RoPE models, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55514?

CVE-2026-55514 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

Weakness: CWE-617

Which versions are affected by CVE-2026-55514?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.12.00.24.0
vllm PyPIFrom 0.12.00.24.0
vllm PyPIFrom 0.12.00.24.0

Products include Vllm Vllm.

How do I fix CVE-2026-55514?

Upgrade vllm to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-55514 being exploited?

There is no known exploitation of CVE-2026-55514 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-33cg-gxv8-3p8g, MINI-65j4-pmrh-92r8, MINI-67q5-c6xv-mxf4, MINI-j43w-23g3-3cqr, PYSEC-2026-2303.

Is CVE-2026-55514 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free