{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-55514 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.24.0 or later.","what":"CVE-2026-55514 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55514 and fix it if it is affected.\n\nWhat it is: CVE-2026-55514 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55514 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0\n- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0\n- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55514/ (Markdown: https://insights.sbomify.com/CVE-2026-55514/index.md)","id":"CVE-2026-55514","markdown":"https://insights.sbomify.com/CVE-2026-55514/index.md","name":"CVE-2026-55514","record":{"aliases":["GHSA-33cg-gxv8-3p8g","MINI-65j4-pmrh-92r8","MINI-67q5-c6xv-mxf4","MINI-j43w-23g3-3cqr","PYSEC-2026-2303"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference library","requires_auth":"low_privilege","summary":"Remote attackers can crash the vLLM server by sending specific prompt embeds to M-RoPE models, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM denial of service via prompt embeds on M-RoPE models","id":"CVE-2026-55514","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Snipe-IT: Cross-company deletion of pending checkout acceptances via unscoped report endpoint","id":"CVE-2026-55515"},"packages":[{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.12.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-33cg-gxv8-3p8g"},{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.12.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-33cg-gxv8-3p8g"},{"ecosystem":"PyPI","fixed":["0.24.0"],"introduced":["0.12.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2303"}],"prev":{"headline":"nebula-mesh: Web UI host creation ignores configured enrollment token TTL and mints 24-hour bearer enrollment tokens","id":"CVE-2026-55513"},"products":["vllm"],"published":"2026-07-06","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-06","vendors":["vllm-project"]},"summary":"Remote attackers can crash the vLLM server by sending specific prompt embeds to M-RoPE models, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-55514/"}