# CVE-2026-55514: vLLM denial of service via prompt embeds on M-RoPE models

> Remote attackers can crash the vLLM server by sending specific prompt embeds to M-RoPE models, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-33cg-gxv8-3p8g, MINI-65j4-pmrh-92r8, MINI-67q5-c6xv-mxf4, MINI-j43w-23g3-3cqr, PYSEC-2026-2303

## What is CVE-2026-55514?

CVE-2026-55514 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-55514?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.12.0 | 0.24.0 |
| `vllm` | PyPI | From 0.12.0 | 0.24.0 |
| `vllm` | PyPI | From 0.12.0 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-55514?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-55514 being exploited?

There is no known exploitation of CVE-2026-55514 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55514 and fix it if it is affected.

What it is: CVE-2026-55514 is a high-severity denial of service vulnerability in Vllm Vllm, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55514 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0
- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0
- vllm (PyPI): affected from 0.12.0; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55514/ (Markdown: https://insights.sbomify.com/CVE-2026-55514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55514
- OSV: https://osv.dev/vulnerability/CVE-2026-55514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55514/
Summaries are generated and may contain mistakes; the official description above is the record.
