# CVE-2026-55518: Avo: Missing Authorization in Avo Association Attach Endpoint Allows Unauthorized Relationship Manipulation and Privilege Escalation

> An authenticated low-privileged user can bypass UI controls to manipulate associations via direct POST requests, leading to privilege escalation and data exposure.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-8fq9-273g-6mrg

## What is CVE-2026-55518?

CVE-2026-55518 is a critical missing authorization vulnerability in avo-hq avo, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Avo is a framework to create admin panels for Ruby on Rails apps. Prior to 3.32.1 and 4.0.0.beta.51, Avo's association attach workflow checks attach_<association>? in the UI and GET /resources/:resource/:id/:related/new path, but the actual write endpoint, POST /resources/:resource/:id/:related, does not run the same authorization check before mutating the association through Avo::AssociationsController#create. An authenticated low-privileged Avo user can bypass hidden or disabled attach controls and directly attach related records to a parent record by sending a crafted POST request, which can lead to privilege escalation and cross-tenant data exposure where associations represent authorization-bearing relationships. This issue is fixed in versions 3.32.1 and 4.0.0.beta.51.

Weakness: CWE-863 (Incorrect Authorization), CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-55518?

4 open source packages ship an affected version, including avo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `avo` | RubyGems | All versions | 3.32.1 |
| `avo` | RubyGems | All versions | 3.32.1 |
| `avo` | RubyGems | From 4.0.0.beta.1 | 4.0.0.beta.51 |
| `avo` | RubyGems | From 4.0.0.beta.1 | 4.0.0.beta.51 |

## How do I fix CVE-2026-55518?

Upgrade avo to a fixed version for your release line: 3.32.1 or 4.0.0.beta.51.

## Is CVE-2026-55518 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55518 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55518 and fix it if it is affected.

What it is: CVE-2026-55518 is a critical missing authorization vulnerability in avo-hq avo, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55518 exists.

Affected packages and fixed versions:
- avo (RubyGems): affected all versions; fixed in 3.32.1
- avo (RubyGems): affected all versions; fixed in 3.32.1
- avo (RubyGems): affected from 4.0.0.beta.1; fixed in 4.0.0.beta.51
- avo (RubyGems): affected from 4.0.0.beta.1; fixed in 4.0.0.beta.51

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55518/ (Markdown: https://insights.sbomify.com/CVE-2026-55518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55518
- OSV: https://osv.dev/vulnerability/CVE-2026-55518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55518/
Summaries are generated and may contain mistakes; the official description above is the record.
