{"answers":{"affected":"4 open source packages ship an affected version, including org.yamcs:yamcs-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55521 exists.","fix":"Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.","what":"CVE-2026-55521 is a high-severity missing authorization vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55521 and fix it if it is affected.\n\nWhat it is: CVE-2026-55521 is a high-severity missing authorization vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55521 exists.\n\nAffected packages and fixed versions:\n- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8\n- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8\n- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2\n- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55521/ (Markdown: https://insights.sbomify.com/CVE-2026-55521/index.md)","id":"CVE-2026-55521","markdown":"https://insights.sbomify.com/CVE-2026-55521/index.md","name":"CVE-2026-55521","record":{"aliases":["GHSA-962x-ccwf-8x6p"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mission control framework","requires_auth":"low_privilege","summary":"Low-privilege users can access telemetry metadata and disrupt telecommand handling due to missing authorization checks in Yamcs Core API.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits authorization checks in IndexesApi.listPacketIndex, IndexesApi.listEventIndex, Cop1Api.disable, Cop1Api.resume, Cop1Api.initialize, Cop1Api.updateConfig, and TimeApi.setTime. An authenticated low-privilege user can read packet and event index metadata without ObjectPrivilegeType.ReadPacket, alter COP-1 link state without SystemPrivilege.ControlLinks, and manipulate simulation time. These operations can disclose telemetry metadata, disrupt telecommand handling, and affect system integrity and availability. This issue is fixed in versions 5.12.8 and 5.13.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Yamcs : Multiple Missing Function Level Access Control vulnerabilities in Yamcs Core API","id":"CVE-2026-55521","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":5,"next":{"headline":"PraisonAI workflow include bypasses tools.py autoload opt-in and executes included recipe code","id":"CVE-2026-55522"},"packages":[{"ecosystem":"Maven","fixed":["5.12.8"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":null,"source":"GHSA-962x-ccwf-8x6p"},{"ecosystem":"Maven","fixed":["5.12.8"],"introduced":["0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":"pkg:maven/org.yamcs/yamcs-core","source":"GHSA-962x-ccwf-8x6p"},{"ecosystem":"Maven","fixed":["5.13.2"],"introduced":["5.13.0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":null,"source":"GHSA-962x-ccwf-8x6p"},{"ecosystem":"Maven","fixed":["5.13.2"],"introduced":["5.13.0"],"last_affected":[],"package":"org.yamcs:yamcs-core","purl":"pkg:maven/org.yamcs/yamcs-core","source":"GHSA-962x-ccwf-8x6p"}],"prev":{"headline":"Protego: Exponential backtracking ReDoS in robots.txt URL wildcard matching","id":"CVE-2026-55520"},"products":["yamcs"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["yamcs"]},"summary":"Low-privilege users can access telemetry metadata and disrupt telecommand handling due to missing authorization checks in Yamcs Core API.","url":"https://insights.sbomify.com/CVE-2026-55521/"}