CVE-2026-55522 PraisonAI workflow include bypasses tools.py autoload opt-in and executes included recipe code
Attackers can execute arbitrary Python code by including malicious local recipes, bypassing security gates in PraisonAI libraries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-55522?
CVE-2026-55522 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 5 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
PraisonAI is a multi-agent teams system. In versions 3.9.26 through 4.6.57 of praiseonai and 0.12.12 through 1.6.57 of praiseonaiagents, the workflow "include" feature is vulnerable to code execution. Workflow._execute_include() implicitly imports and runs an included recipe's tools.py via a raw importlib.util.spec_from_file_location() and spec.loader.exec_module() call, without honoring the PRAISONAI_ALLOW_TEMPLATE_TOOLS/PRAISONAI_ALLOW_LOCAL_TOOLS autoload opt-in gates or routing through the centralized safe loader that protects the other tools.py autoload paths. As a result, a workflow that includes an attacker-controlled local recipe directory executes arbitrary module-level Python code during include setup, before any child workflow parsing or model call, and the same sink is reachable through the higher-level praisonai.recipe.run() recipe API. An attacker who can cause a victim process to run a workflow or recipe that includes an untrusted local recipe achieves arbitrary Python code execution as the PraisonAI process user, a variant that bypasses the hardening applied to the previously disclosed automatic tools.py RCE advisory family. This issue has been fixed in version 4.6.58 of praisonai and 1.6.58 of praisonaiagents.
Which versions are affected by CVE-2026-55522?
6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai.
| Package | Affected | Fixed in |
|---|---|---|
praisonaiagents PyPI | From 0.12.12 | 1.6.58 |
praisonaiagents PyPI | From 0.12.12 | 1.6.58 |
praisonaiagents PyPI | From 0.12.12 | 1.6.58 |
PraisonAI PyPI | From 3.9.26 | 4.6.58 |
praisonai PyPI | From 3.9.26 | 4.6.58 |
praisonai PyPI | From 3.9.26 | 4.6.58 |
How do I fix CVE-2026-55522?
Upgrade praisonaiagents to 1.6.58 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55522 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55522 exists.
Sources
Also known as GHSA-hxmv-c4g6-5fqc, PYSEC-2026-3891, PYSEC-2026-3903.