{"answers":{"affected":"6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55522 exists.","fix":"Upgrade praisonaiagents to 1.6.58 or later.","what":"CVE-2026-55522 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 5 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55522 and fix it if it is affected.\n\nWhat it is: CVE-2026-55522 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 5 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55522 exists.\n\nAffected packages and fixed versions:\n- praisonaiagents (PyPI): affected from 0.12.12; fixed in 1.6.58\n- praisonaiagents (PyPI): affected from 0.12.12; fixed in 1.6.58\n- praisonaiagents (PyPI): affected from 0.12.12; fixed in 1.6.58\n- PraisonAI (PyPI): affected from 3.9.26; fixed in 4.6.58\n- praisonai (PyPI): affected from 3.9.26; fixed in 4.6.58\n- praisonai (PyPI): affected from 3.9.26; fixed in 4.6.58\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55522/ (Markdown: https://insights.sbomify.com/CVE-2026-55522/index.md)","id":"CVE-2026-55522","markdown":"https://insights.sbomify.com/CVE-2026-55522/index.md","name":"CVE-2026-55522","record":{"aliases":["GHSA-hxmv-c4g6-5fqc","PYSEC-2026-3891","PYSEC-2026-3903"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python AI agent library","requires_auth":"none","summary":"Attackers can execute arbitrary Python code by including malicious local recipes, bypassing security gates in PraisonAI libraries.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"PraisonAI is a multi-agent teams system. In versions 3.9.26 through 4.6.57 of praiseonai and 0.12.12 through 1.6.57 of praiseonaiagents, the workflow \"include\" feature is vulnerable to code execution. Workflow._execute_include() implicitly imports and runs an included recipe's tools.py via a raw importlib.util.spec_from_file_location() and spec.loader.exec_module() call, without honoring the PRAISONAI_ALLOW_TEMPLATE_TOOLS/PRAISONAI_ALLOW_LOCAL_TOOLS autoload opt-in gates or routing through the centralized safe loader that protects the other tools.py autoload paths. As a result, a workflow that includes an attacker-controlled local recipe directory executes arbitrary module-level Python code during include setup, before any child workflow parsing or model call, and the same sink is reachable through the higher-level praisonai.recipe.run() recipe API. An attacker who can cause a victim process to run a workflow or recipe that includes an untrusted local recipe achieves arbitrary Python code execution as the PraisonAI process user, a variant that bypasses the hardening applied to the previously disclosed automatic tools.py RCE advisory family. This issue has been fixed in version 4.6.58 of praisonai and 1.6.58 of praisonaiagents.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PraisonAI workflow include bypasses tools.py autoload opt-in and executes included recipe code","id":"CVE-2026-55522","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":1,"next":{"headline":"PraisonAI has a`web_crawl` SSRF protection bypass via unchecked redirect targets","id":"CVE-2026-55523"},"packages":[{"ecosystem":"PyPI","fixed":["4.6.58"],"introduced":["3.9.26"],"last_affected":[],"package":"PraisonAI","purl":null,"source":"GHSA-hxmv-c4g6-5fqc"},{"ecosystem":"PyPI","fixed":["4.6.58"],"introduced":["3.9.26"],"last_affected":[],"package":"praisonai","purl":"pkg:pypi/praisonai","source":"GHSA-hxmv-c4g6-5fqc"},{"ecosystem":"PyPI","fixed":["4.6.58"],"introduced":["3.9.26"],"last_affected":[],"package":"praisonai","purl":"pkg:pypi/praisonai","source":"PYSEC-2026-3891"},{"ecosystem":"PyPI","fixed":["1.6.58"],"introduced":["0.12.12"],"last_affected":[],"package":"praisonaiagents","purl":null,"source":"GHSA-hxmv-c4g6-5fqc"},{"ecosystem":"PyPI","fixed":["1.6.58"],"introduced":["0.12.12"],"last_affected":[],"package":"praisonaiagents","purl":"pkg:pypi/praisonaiagents","source":"GHSA-hxmv-c4g6-5fqc"},{"ecosystem":"PyPI","fixed":["1.6.58"],"introduced":["0.12.12"],"last_affected":[],"package":"praisonaiagents","purl":"pkg:pypi/praisonaiagents","source":"PYSEC-2026-3903"}],"prev":{"headline":"Yamcs : Multiple Missing Function Level Access Control vulnerabilities in Yamcs Core API","id":"CVE-2026-55521"},"products":["PraisonAI","praisonaiagents"],"published":"2026-08-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-06","vendors":["MervinPraison"]},"summary":"Attackers can execute arbitrary Python code by including malicious local recipes, bypassing security gates in PraisonAI libraries.","url":"https://insights.sbomify.com/CVE-2026-55522/"}