# CVE-2026-55527: praisonaiagents vulnerable to arbitrary file write via unsanitized `user_id` in `FileMemory.__init__()` — path traversal to any writable location

> Attackers can write arbitrary files by exploiting unsanitized user IDs in PraisonAI's FileMemory, potentially compromising system integrity.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-gxmw-5f7x-6g22, PYSEC-2026-3902

## What is CVE-2026-55527?

CVE-2026-55527 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.58, the FileMemory constructor joins unsanitized user_id into self.user_path. A caller supplying ../ or path separators can escape the memory directory and write JSON data to arbitrary process-writable locations. The fix sanitizes user_id before constructing self.user_path. This issue is fixed in version 1.6.58.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55527?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |

## How do I fix CVE-2026-55527?

Upgrade praisonaiagents to 1.6.58 or later.

## Is CVE-2026-55527 being exploited?

There is no known exploitation of CVE-2026-55527 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55527 and fix it if it is affected.

What it is: CVE-2026-55527 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55527 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55527/ (Markdown: https://insights.sbomify.com/CVE-2026-55527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55527
- OSV: https://osv.dev/vulnerability/CVE-2026-55527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55527/
Summaries are generated and may contain mistakes; the official description above is the record.
