# CVE-2026-55528: praisonaiagents: AgentServer declares auth_token but never enforces it on any route (CWE-862)

> Attackers can bypass authentication in PraisonAI agents to subscribe or publish data without valid tokens when auth is configured.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-7g3p-92qq-8wvh, PYSEC-2026-3899

## What is CVE-2026-55528?

CVE-2026-55528 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.58, AgentServer exposes ServerConfig.auth_token but AgentServer._create_app does not check it on any route. A remote caller can subscribe, publish, and perform other actions without a valid bearer token or X-Auth-Token even when authentication is configured. This issue is fixed in version 1.6.58.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-55528?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |

## How do I fix CVE-2026-55528?

Upgrade praisonaiagents to 1.6.58 or later.

## Is CVE-2026-55528 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55528 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55528 and fix it if it is affected.

What it is: CVE-2026-55528 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55528 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55528/ (Markdown: https://insights.sbomify.com/CVE-2026-55528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55528
- OSV: https://osv.dev/vulnerability/CVE-2026-55528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55528/
Summaries are generated and may contain mistakes; the official description above is the record.
