# CVE-2026-55529: PraisonAI has an origin validation bypass in MCP HTTP Stream transport that allows browser-mediated unauthenticated tool execution on local MCP server

> Attackers can bypass origin validation to execute tools on local MCP servers via malicious webpages, requiring an upgrade to PraisonAI.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-wj6g-v78p-6fx3, PYSEC-2026-3896

## What is CVE-2026-55529?

CVE-2026-55529 is a medium-severity authentication bypass vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonai 4.6.58, the MCP HTTP Stream _validate_origin method accepts request_origin.startswith(allowed), so the attacker-controlled localhost.evil.example HTTP origin matches the localhost allowlist. Without an API key, a malicious webpage can submit tools/call requests to the local MCP server and execute exposed tools. This issue is fixed in version 4.6.58.

Weakness: CWE-346 (Origin Validation Error), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-55529?

3 open source packages ship an affected version, including praisonai and PraisonAI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.58 |
| `praisonai` | PyPI | All versions | 4.6.58 |
| `PraisonAI` | PyPI | All versions | 4.6.58 |

## How do I fix CVE-2026-55529?

Upgrade praisonai to 4.6.58 or later.

## Is CVE-2026-55529 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55529 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55529 and fix it if it is affected.

What it is: CVE-2026-55529 is a medium-severity authentication bypass vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55529 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.58
- praisonai (PyPI): affected all versions; fixed in 4.6.58
- PraisonAI (PyPI): affected all versions; fixed in 4.6.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55529/ (Markdown: https://insights.sbomify.com/CVE-2026-55529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55529
- OSV: https://osv.dev/vulnerability/CVE-2026-55529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55529/
Summaries are generated and may contain mistakes; the official description above is the record.
