# CVE-2026-55530: praisonaiagents: ast_grep_rewrite rewrites arbitrary files without the @require_approval gate enforced on every sibling mutation tool

> Attackers can modify arbitrary files via the ast_grep_rewrite tool in PraisonAI because it bypasses the required approval gate.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-cfxv-8fw8-rwpv, PYSEC-2026-3901

## What is CVE-2026-55530?

CVE-2026-55530 is a medium-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonaiagents 1.6.58, ast_grep_rewrite lacks the @require_approval decorator used by sibling mutation tools. With dry_run=False, an agent-controlled call can pass --update-all and a broad path to rewrite matching files without the expected authorization gate. This issue is fixed in version 1.6.58.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-55530?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |
| `praisonaiagents` | PyPI | All versions | 1.6.58 |

## How do I fix CVE-2026-55530?

Upgrade praisonaiagents to 1.6.58 or later.

## Is CVE-2026-55530 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55530 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55530 and fix it if it is affected.

What it is: CVE-2026-55530 is a medium-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55530 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55530/ (Markdown: https://insights.sbomify.com/CVE-2026-55530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55530
- OSV: https://osv.dev/vulnerability/CVE-2026-55530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55530/
Summaries are generated and may contain mistakes; the official description above is the record.
