# CVE-2026-55540: PraisonAI: [Path Traversal] agent tools escape the configured workspace via symlinks

> Attackers can read files outside the configured workspace by exploiting symlink handling in PraisonAI's path validation logic.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-ch89-h4r2-c8f8, PYSEC-2026-3888

## What is CVE-2026-55540?

CVE-2026-55540 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonai 4.6.51, is_path_within_directory() uses os.path.abspath() rather than os.path.realpath() for the workspace boundary. A symlink inside workspace can point outside and still pass the check, allowing read_file and other code tools to access files outside the configured workspace. This issue is fixed in version 4.6.58.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55540?

3 open source packages ship an affected version, including praisonai and PraisonAI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.58 |
| `praisonai` | PyPI | All versions | 4.6.58 |
| `PraisonAI` | PyPI | All versions | 4.6.58 |

## How do I fix CVE-2026-55540?

Upgrade praisonai to 4.6.58 or later.

## Is CVE-2026-55540 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55540 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55540 and fix it if it is affected.

What it is: CVE-2026-55540 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55540 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.58
- praisonai (PyPI): affected all versions; fixed in 4.6.58
- PraisonAI (PyPI): affected all versions; fixed in 4.6.58

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55540/ (Markdown: https://insights.sbomify.com/CVE-2026-55540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55540
- OSV: https://osv.dev/vulnerability/CVE-2026-55540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55540/
Summaries are generated and may contain mistakes; the official description above is the record.
