# CVE-2026-55543: TuxGuitar: Arbitrary Code Execution via maliciously crafted `.tg` file

> Attackers can execute arbitrary code by tricking users into opening a malicious .tg file that loads an unverified class from an embedded archive.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-55543, GHSA-v66p-c82h-w3cq, UBUNTU-CVE-2026-55543, openSUSE-SU-2026:11645-1

## What is CVE-2026-55543?

CVE-2026-55543 is a high-severity code injection vulnerability in helge17 tuxguitar, published on 16 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

TuxGuitar is an open-source guitar tablature editor. Prior to 2.1.0, an untrusted .tg file can set gervil.soundbank.path to reference an on-disk archive, including the .tg file itself, whose META-INF/services/javax.sound.midi.Soundbank entry names an attacker-supplied class stored in that archive. When a user opens the file, JARSoundbankReader uses an unverified class loader to load and instantiate that class, executing its constructor with the privileges of the TuxGuitar process. This issue is fixed in version 2.1.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-55543?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tuxguitar` | openSUSE:Tumbleweed | All versions | 2.1.0-1.1 |

## How do I fix CVE-2026-55543?

Upgrade to a fixed version.

## Is CVE-2026-55543 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55543 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55543 and fix it if it is affected.

What it is: CVE-2026-55543 is a high-severity code injection vulnerability in helge17 tuxguitar, published on 16 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55543 exists.

Affected product: helge17 tuxguitar. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55543/ (Markdown: https://insights.sbomify.com/CVE-2026-55543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55543
- OSV: https://osv.dev/vulnerability/CVE-2026-55543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55543/
Summaries are generated and may contain mistakes; the official description above is the record.
