CVE-2026-55545 Yamcs: WebSocket subscription handlers omit the privilege checks their REST siblings enforce
Low-privilege users can access restricted telemetry and database changes via WebSocket due to missing privilege checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55545?
CVE-2026-55545 is a medium-severity missing authorization vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs WebSocket subscription handlers fail to enforce the privileges required by equivalent REST endpoints. PacketsApi.subscribePackets exposes the packets WebSocket topic without ObjectPrivilegeType.ReadPacket, ProcessingApi.subscribeAlgorithmStatus exposes the algorithm-status WebSocket topic without ObjectPrivilegeType.ReadAlgorithm, and MdbOverrideApi.subscribeMdbChanges exposes the mdb-changes WebSocket topic without SystemPrivilege.GetMissionDatabase. A low-privilege authenticated user can receive telemetry packets, algorithm status, and mission database change information outside the assigned authorization scope. This issue is fixed in versions 5.12.8 and 5.13.2.
Weakness: CWE-862
Which versions are affected by CVE-2026-55545?
4 open source packages ship an affected version, including org.yamcs:yamcs-core.
| Package | Affected | Fixed in |
|---|---|---|
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
How do I fix CVE-2026-55545?
Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55545 being exploited?
There is no known exploitation of CVE-2026-55545 in the wild and no public exploit code.
Sources
Also known as GHSA-fwww-cp23-7f5g.