{"answers":{"affected":"3 open source packages ship an affected version, including qwed-mcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55546 exists.","fix":"Upgrade qwed-mcp to 0.2.1 or later.","what":"CVE-2026-55546 is a critical code injection vulnerability in QWED-AI qwed-mcp, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55546 and fix it if it is affected.\n\nWhat it is: CVE-2026-55546 is a critical code injection vulnerability in QWED-AI qwed-mcp, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55546 exists.\n\nAffected packages and fixed versions:\n- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1\n- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1\n- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55546/ (Markdown: https://insights.sbomify.com/CVE-2026-55546/index.md)","id":"CVE-2026-55546","markdown":"https://insights.sbomify.com/CVE-2026-55546/index.md","name":"CVE-2026-55546","record":{"aliases":["GHSA-mw6r-2hvm-4rp2","PYSEC-2026-3915"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Python MCP verification library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsanitized input in QWED-MCP's math verification function if integrated by downstream applications.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"QWED-MCP is a deterministic verification gateway for MCP. Prior to 0.2.1, verify_math_expression() in src/qwed_mcp/engines/math_engine.py passes attacker-controlled expression and claimed_result strings directly to SymPy's parse_expr() after only normalizing caret syntax to Python exponent syntax, without restricting global_dict, removing Python built-ins, or validating the expression AST. Because parse_expr() calls Python's eval() with built-ins available, an attacker who can cause a downstream caller to pass untrusted input to this public library function can use Python import functionality to execute arbitrary operating-system commands as the qwed-mcp process user, read or modify accessible data, exfiltrate process secrets, or reach internal services. The default MCP tool registry does not expose verify_math_expression(), so exploitation requires a downstream integration that invokes the library API with attacker-controlled input. This issue is fixed in version 0.2.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"QWED-MCP: Unsafe SymPy `parse_expr()` Remote Code Execution via Unsanitized Math Expression Input","id":"CVE-2026-55546","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Yamcs's Missing Authorization on Role and Privilege Enumeration Endpoints Allows Any Authenticated User to Disclose Full Security Configuration","id":"CVE-2026-55547"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"qwed-mcp","purl":null,"source":"GHSA-mw6r-2hvm-4rp2"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"qwed-mcp","purl":"pkg:pypi/qwed-mcp","source":"GHSA-mw6r-2hvm-4rp2"},{"ecosystem":"PyPI","fixed":["0.2.1"],"introduced":["0"],"last_affected":[],"package":"qwed-mcp","purl":"pkg:pypi/qwed-mcp","source":"PYSEC-2026-3915"}],"prev":{"headline":"Yamcs: WebSocket subscription handlers omit the privilege checks their REST siblings enforce","id":"CVE-2026-55545"},"products":["qwed-mcp"],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["QWED-AI"]},"summary":"Attackers can execute arbitrary code via unsanitized input in QWED-MCP's math verification function if integrated by downstream applications.","url":"https://insights.sbomify.com/CVE-2026-55546/"}