# CVE-2026-55546: QWED-MCP: Unsafe SymPy `parse_expr()` Remote Code Execution via Unsanitized Math Expression Input

> Attackers can execute arbitrary code via unsanitized input in QWED-MCP's math verification function if integrated by downstream applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-mw6r-2hvm-4rp2, PYSEC-2026-3915

## What is CVE-2026-55546?

CVE-2026-55546 is a critical code injection vulnerability in QWED-AI qwed-mcp, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

QWED-MCP is a deterministic verification gateway for MCP. Prior to 0.2.1, verify_math_expression() in src/qwed_mcp/engines/math_engine.py passes attacker-controlled expression and claimed_result strings directly to SymPy's parse_expr() after only normalizing caret syntax to Python exponent syntax, without restricting global_dict, removing Python built-ins, or validating the expression AST. Because parse_expr() calls Python's eval() with built-ins available, an attacker who can cause a downstream caller to pass untrusted input to this public library function can use Python import functionality to execute arbitrary operating-system commands as the qwed-mcp process user, read or modify accessible data, exfiltrate process secrets, or reach internal services. The default MCP tool registry does not expose verify_math_expression(), so exploitation requires a downstream integration that invokes the library API with attacker-controlled input. This issue is fixed in version 0.2.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55546?

3 open source packages ship an affected version, including qwed-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qwed-mcp` | PyPI | All versions | 0.2.1 |
| `qwed-mcp` | PyPI | All versions | 0.2.1 |
| `qwed-mcp` | PyPI | All versions | 0.2.1 |

## How do I fix CVE-2026-55546?

Upgrade qwed-mcp to 0.2.1 or later.

## Is CVE-2026-55546 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55546 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55546 and fix it if it is affected.

What it is: CVE-2026-55546 is a critical code injection vulnerability in QWED-AI qwed-mcp, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55546 exists.

Affected packages and fixed versions:
- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1
- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1
- qwed-mcp (PyPI): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55546/ (Markdown: https://insights.sbomify.com/CVE-2026-55546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55546
- OSV: https://osv.dev/vulnerability/CVE-2026-55546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55546/
Summaries are generated and may contain mistakes; the official description above is the record.
