# CVE-2026-55548: Yamcs: Insecure Direct Object Reference (IDOR) in PacketsApi allows unprivileged users to dump all telemetry packets

> Unprivileged users can dump all telemetry packets by exploiting missing authorization checks in the PacketsApi export endpoint.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-8xjq-pr36-ccgf

## What is CVE-2026-55548?

CVE-2026-55548 is a medium-severity missing authorization vulnerability in yamcs, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, the PacketsApi.exportPackets endpoint in yamcs-core/src/main/java/org/yamcs/http/api/PacketsApi.java failed to enforce object-level ReadPacket privileges when a request omitted specific packet names: with an empty name list the ctx.checkObjectPrivileges(ObjectPrivilegeType.ReadPacket, nameSet) call passed over an empty set, no WHERE pname IN filter was applied to the resulting SELECT * FROM tm query, and the onTuple handler streamed every retrieved packet without any per-row authorization check, so a low-privileged or zero-privilege authenticated user could dump the entire raw telemetry packet archive and bypass the role-based access control model. This issue is fixed in versions 5.12.8 and 5.13.2, which enforce per-packet ReadPacket checks in exportPackets.

Weakness: CWE-862 (Missing Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-55548?

4 open source packages ship an affected version, including org.yamcs:yamcs-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |

Products: Spaceapplications Yamcs.

## How do I fix CVE-2026-55548?

Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.

## Is CVE-2026-55548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55548 exists.

## Other vulnerabilities in yamcs

- [CVE-2026-46562](https://insights.sbomify.com/CVE-2026-46562/): Yamcs: Remote Code Execution via Mission Database algorithm override (critical 9.8)
- [CVE-2026-44632](https://insights.sbomify.com/CVE-2026-44632/): Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory` (critical 9.1)
- [CVE-2026-46621](https://insights.sbomify.com/CVE-2026-46621/): Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection (critical 9.1)
- [CVE-2023-45278](https://insights.sbomify.com/CVE-2023-45278/): Yamcs API Directory Traversal vulnerability (critical 9.1)
- [CVE-2023-45277](https://insights.sbomify.com/CVE-2023-45277/): Yamcs Path Traversal vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55548 and fix it if it is affected.

What it is: CVE-2026-55548 is a medium-severity missing authorization vulnerability in yamcs, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55548 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55548/ (Markdown: https://insights.sbomify.com/CVE-2026-55548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55548
- OSV: https://osv.dev/vulnerability/CVE-2026-55548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55548/
Summaries are generated and may contain mistakes; the official description above is the record.
