# CVE-2026-55549: Yamcs: Reflected XSS in the URL of the Authorize Endpoint

> Attackers can execute JavaScript via a crafted authorization URL, potentially stealing authentication tokens and compromising user accounts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** GHSA-rxpg-wjf8-qv9c

## What is CVE-2026-55549?

CVE-2026-55549 is a medium-severity cross-site scripting vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Yamcs is a mission control framework. Prior to 5.9.4, Yamcs reflects an attacker-controlled redirect_uri parameter from GET /auth/authorize into yamcs-core/src/main/resources/auth/templates/authorize.html without adequate HTML escaping by yamcs-core/src/main/java/org/yamcs/http/auth/AuthHandler.java and yamcs-core/src/main/java/org/yamcs/http/HandlerContext.java. A crafted authorization URL can execute JavaScript when opened by a Yamcs user. The script can access browser-held authentication material and transmit it to an attacker, enabling account compromise. This issue is fixed in version 5.9.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55549?

2 open source packages ship an affected version, including org.yamcs:yamcs-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.9.4 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.9.4 |

## How do I fix CVE-2026-55549?

Upgrade org.yamcs:yamcs-core to 5.9.4 or later.

## Is CVE-2026-55549 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55549 exists.

Public exploit code:

- Yamcs <=5.8.6 - Cross-Site Scripting (nuclei): http/cves/2026/CVE-2026-55549.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55549 and fix it if it is affected.

What it is: CVE-2026-55549 is a medium-severity cross-site scripting vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55549 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.9.4
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55549/ (Markdown: https://insights.sbomify.com/CVE-2026-55549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55549
- OSV: https://osv.dev/vulnerability/CVE-2026-55549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55549/
Summaries are generated and may contain mistakes; the official description above is the record.
