# CVE-2026-55552: Yamcs: Unauthenticated Directory Traversal

> Unauthenticated attackers can read arbitrary host files via path traversal in Yamcs mission control framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-9jg3-g3wh-w9pj

## What is CVE-2026-55552?

CVE-2026-55552 is a high-severity path traversal vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.11.13, Yamcs StaticFileHandler.locateFile resolves an unauthenticated request path without using Path.normalize and Path.toAbsolutePath to confirm that the absolute path remains within the configured staticRoots. A path containing traversal segments can escape the intended web root and return an arbitrary readable host file. The flaw is in yamcs-core/src/main/java/org/yamcs/http/StaticFileHandler.java and can disclose sensitive operating-system and application data. This issue is fixed in version 5.11.13, and the 5.12 line is fixed from version 5.12.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-55552?

2 open source packages ship an affected version, including org.yamcs:yamcs-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.0 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.0 |

## How do I fix CVE-2026-55552?

Upgrade org.yamcs:yamcs-core to 5.12.0 or later.

## Is CVE-2026-55552 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55552 exists.

Public exploit code:

- Yamcs <=5.11.12 - Arbitrary File Read (nuclei): http/cves/2026/CVE-2026-55552.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55552 and fix it if it is affected.

What it is: CVE-2026-55552 is a high-severity path traversal vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55552 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.0
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55552/ (Markdown: https://insights.sbomify.com/CVE-2026-55552/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55552
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55552
- OSV: https://osv.dev/vulnerability/CVE-2026-55552

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55552/
Summaries are generated and may contain mistakes; the official description above is the record.
