# CVE-2026-55555: Dompdf: File existence oracle via font-face stylesheet declaration

> Attackers can enumerate server files and cause denial of service by exploiting memory exhaustion differences in Dompdf's font-face handling.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-55555, GHSA-7x2p-4jvh-6384, UBUNTU-CVE-2026-55555

## What is CVE-2026-55555?

CVE-2026-55555 is a low-severity vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a File Existence Oracle attack through the manipulation of the CSS @font-face directive. By providing malicious HTML that references local files via the file:// protocol repeatedly, an attacker can trigger PHP memory exhaustion. Because Dompdf behaves differently depending on whether a referenced local file exists (an existing file is processed repeatedly until it triggers an "Allowed memory size exhausted" crash, whereas a missing file fails fast or is ignored and never hits the memory limit), an attacker can use this observable discrepancy as an oracle to enumerate sensitive files on the server regardless of CHROOT restrictions. Exploitation requires the attacker to supply unrestricted or unsanitized HTML in a request that permits large data, plus a configuration where Dompdf's memory limit is low enough to be exhausted (with  $_dompdf_show_warnings=true  making the overflow easier to reach). This issue has been fixed in version 3.16.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2026-55555?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |
| `dompdf/dompdf` | Packagist | All versions | 3.1.6 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2026-55555?

Upgrade dompdf/dompdf to 3.1.6 or later.

## Is CVE-2026-55555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55555 exists.

## Other vulnerabilities in dompdf

- [CVE-2023-24813](https://insights.sbomify.com/CVE-2023-24813/): URI validation failure on SVG parsing. Bypass of CVE-2023-23924 (critical 10.0)
- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55555 and fix it if it is affected.

What it is: CVE-2026-55555 is a low-severity vulnerability in dompdf, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55555 exists.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6
- dompdf/dompdf (Packagist): affected all versions; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55555/ (Markdown: https://insights.sbomify.com/CVE-2026-55555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55555
- OSV: https://osv.dev/vulnerability/CVE-2026-55555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55555/
Summaries are generated and may contain mistakes; the official description above is the record.
