CVE-2026-55559 Yamcs: Remote Code Execution via instance-template argument YAML injection (createInstance)
Attackers can execute arbitrary commands by injecting YAML into instance templates, affecting Yamcs mission control deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55559?
CVE-2026-55559 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs inserts templateArgs from POST /api/instances and PATCH /api/instances/{instance} into YAML through VarStatement.append in yamcs-core/src/main/java/org/yamcs/templating/VarStatement.java without YAML-context escaping. The rendered configuration is parsed by YamcsServer.createInstance and loaded by YamcsServerInstance, allowing an attacker to inject a services entry for org.yamcs.ProcessRunner. Deployments without security.yaml expose the operation through the guest superuser, while secured deployments require SystemPrivilege.CreateInstances. Successful exploitation executes commands as the Yamcs service account. This issue is fixed in versions 5.12.8 and 5.13.2.
Which versions are affected by CVE-2026-55559?
4 open source packages ship an affected version, including org.yamcs:yamcs-core.
| Package | Affected | Fixed in |
|---|---|---|
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
How do I fix CVE-2026-55559?
Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55559 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55559 exists.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-73mf-m39p-wpm9.