# CVE-2026-55559: Yamcs: Remote Code Execution via instance-template argument YAML injection (createInstance)

> Attackers can execute arbitrary commands by injecting YAML into instance templates, affecting Yamcs mission control deployments.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-73mf-m39p-wpm9

## What is CVE-2026-55559?

CVE-2026-55559 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs inserts templateArgs from POST /api/instances and PATCH /api/instances/{instance} into YAML through VarStatement.append in yamcs-core/src/main/java/org/yamcs/templating/VarStatement.java without YAML-context escaping. The rendered configuration is parsed by YamcsServer.createInstance and loaded by YamcsServerInstance, allowing an attacker to inject a services entry for org.yamcs.ProcessRunner. Deployments without security.yaml expose the operation through the guest superuser, while secured deployments require SystemPrivilege.CreateInstances. Successful exploitation executes commands as the Yamcs service account. This issue is fixed in versions 5.12.8 and 5.13.2.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-470 (Use of Externally-Controlled Input to Select Classes or Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-55559?

4 open source packages ship an affected version, including org.yamcs:yamcs-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.8 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |
| `org.yamcs:yamcs-core` | Maven | From 5.13.0 | 5.13.2 |

## How do I fix CVE-2026-55559?

Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.

## Is CVE-2026-55559 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55559 exists.

Public exploit code:

- Unauthenticated RCE in Yamcs mission control via YAML injection in reconfigureInstance() (github_poc): https://github.com/MRdark-ops/CVE-2026-55559

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55559 and fix it if it is affected.

What it is: CVE-2026-55559 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55559 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.8
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2
- org.yamcs:yamcs-core (Maven): affected from 5.13.0; fixed in 5.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55559/ (Markdown: https://insights.sbomify.com/CVE-2026-55559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55559
- OSV: https://osv.dev/vulnerability/CVE-2026-55559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55559/
Summaries are generated and may contain mistakes; the official description above is the record.
