# CVE-2026-55563: Security feature bypass in feast

> Attackers can bypass CI approval checks to execute untrusted code with production cloud credentials in Feast's pull request integration tests.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-2j2x-r73g-hrr5

## What is CVE-2026-55563?

CVE-2026-55563 is a high-severity vulnerability in feast-dev feast, published on 21 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Feast is the open source feature store for AI and machine learning. Prior to 0.65.0, .github/workflows/pr_integration_tests.yml uses pull_request_target with the synchronize event and preserves ok-to-test, approved, or lgtm labels across newly pushed commits, allowing a fork contributor to obtain approval for a benign revision and then run changed code from refs/pull/${{ github.event.pull_request.number }}/merge through privileged make targets. The job exposes GCP, AWS, and Snowflake credentials to that code, enabling runner code execution, credential disclosure, and possible access to downstream cloud resources. An external label-removal integration could mitigate the condition, but no repository workflow provided that protection. This issue is fixed in version 0.65.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-55563?


## How do I fix CVE-2026-55563?

No fix has been published for CVE-2026-55563 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55563 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55563 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55563 and fix it if it is affected.

What it is: CVE-2026-55563 is a high-severity vulnerability in feast-dev feast, published on 21 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55563 exists.

Affected product: feast-dev feast. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55563/ (Markdown: https://insights.sbomify.com/CVE-2026-55563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55563
- OSV: https://osv.dev/vulnerability/CVE-2026-55563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55563/
Summaries are generated and may contain mistakes; the official description above is the record.
