CVE-2026-55565 Yamcs: Authenticated remote code execution via unescaped StreamSQL `LIKE` pattern compiled by Janino (`LikeExpression`)
Authenticated attackers can execute arbitrary code on Yamcs servers by injecting Java code via unescaped SQL LIKE patterns.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55565?
CVE-2026-55565 is a critical code injection vulnerability in yamcs, published on 28 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs LikeExpression.fillCode_getValueReturn in yamcs-core/src/main/java/org/yamcs/yarch/streamsql/LikeExpression.java inserts an unescaped LIKE pattern into Java source compiled by Expression.getCompiledExpression through SimpleCompiler.cook instead of applying ValueExpression.escapeJavaString. The pattern can originate from POST /api/archive/{instance}:executeSql, POST /api/archive/{instance}:streamSql, POST /api/archive/{instance}/tables/{table}:readRows, GET /api/archive/{instance}/events, or activity searches, including paths available with ReadTables, ReadEvents, or ReadActivities. A quote in the pattern can inject Java that runs as the Yamcs server process. This issue is fixed in versions 5.12.8 and 5.13.2.
Weakness: CWE-94
Which versions are affected by CVE-2026-55565?
4 open source packages ship an affected version, including org.yamcs:yamcs-core.
| Package | Affected | Fixed in |
|---|---|---|
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | All versions | 5.12.8 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
org.yamcs:yamcs-core Maven | From 5.13.0 | 5.13.2 |
How do I fix CVE-2026-55565?
Upgrade org.yamcs:yamcs-core to a fixed version for your release line: 5.12.8 or 5.13.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55565 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55565 exists.
Sources
Also known as GHSA-c64q-hj4j-375f.